NCDOR Provides Update Regarding Web Browser Compatibility

Recent security updates to Firefox and Google Chrome web browsers may cause difficulty accessing sites which require NCID authentication.  A series of updates are being implemented in October to ensure security with these browsers. In addition, after October 18, taxpayers who currently use Windows XP with Internet Explorer version 7 or below, will need to update their operating systems.  Failure to do so will result in taxpayers not being able to access the NCDOR e-Business Center. These updates are necessary to ensure North Carolina citizens have safe and secure access to online resources.